XShell5 强制更新?不存在的!

XShell5Xftp5的用户今天(2018年12月26日)开始一启动就告诉你要继续使用就要升级程序,然后点击升级之后直接提示是最新版XShell5然而回去重新启动还是告诉你要继续使用就要升级程序这么一个死循环。根据我目前的测试将时间调回2018年12月25日(只要是26日之前就行)就能正常启动5版本的XShellXftp。【VPStry 推送频道

【旧】XShell/Xftp 5版本启动脚本

【旧】XShell/Xftp 5版本启动脚本

链接:XShell5-Startup-Script
原理:改时间
(仅供测试,建议购买正版软件!)

食用指南

  • 将脚本放置在XShell5Xftp5的安装目录,与XShell.exeXftp.exe同目录下。
  • 使用右键管理员身份执行脚本。
  • 如果启动失败请查看xshell.exe/xftp.exe的详细信息内的数字证书的时间戳,并将脚本内的“25-12-2018”按此格式改为数字证书内的时间戳记录的时间。

注意事项

如果你想更安稳的使用XShell5/Xftp5,可在Hosts内添加以下内容防止XShell5/Xftp5自动升级:

127.0.0.1 transact.netsarang.com
127.0.0.1 update.netsarang.com
127.0.0.1 www.netsarang.com
127.0.0.1 www.netsarang.co.kr
127.0.0.1 sales.netsarang.com

【新】解决方案

随便找个逆向工具例如C32ASM或ollyDBG之类的以16进制打开nslicense.dll,搜索16进制
7F0C81F98033E1010F8680
修改为
7F0C81F98033E101E98100

7F0C81F98033E1010F8380
保存即可。

懒人专用

直接下载对应文件,替换nslicense.dll即可!

Tips:nslicense.dll一般位于此目录C:\Program Files (x86)\NetSarang\Xshell 5
Tips:此补丁文件来源于 https://www.hostloc.com/thread-508605-1-1.html

Vultr注册就送$50,可开日本/新加坡等机房,【点击注册】。
最后修改:2019 年 04 月 08 日 07 : 37 PM

发表评论

2 条评论

  1. 喜楽君

    加油

    1. 松鼠大大
      @喜楽君

      早早早, 生日快乐!!!,嘿嘿